开发

Meta VR 的 XR 插件管理

更新时间: 2026年10月7日
如果你是初次使用 Unity 开发 Meta VR 设备应用,请查看构建你的第一个 VR 项目,创建你的第一个带手势追踪的 VR 应用。
Unity 借助 Unity XR 插件管理系统⁠,支持在各种平台上进行 XR 开发。
以下提供方插件可用于 Meta VR 开发:
  • Unity OpenXR 插件⁠(推荐)
    • 推荐版本:1.15.1
    • 需要 Unity 6 或更高版本、Meta XR SDK v74 或更高版本。
  • Oculus XR 插件⁠(已停用)
    • 推荐版本:4.5.1
    • 需要 Unity 2022 或更高版本、Meta XR SDK v73 或更早版本。
Oculus XR Plugin is deprecated
Oculus XR 插件已停用并计划移除。请改用 Unity OpenXR 插件。

Unity OpenXR 插件

Unity OpenXR 插件⁠旨在统一各种 OpenXR 后端。
使用 Unity OpenXR 插件具有以下限制:
  • Unity 6 以下版本和 Meta XR 核心 SDK v74 以下版本均不支持 Depth API。
  • Depth API 遮挡功能 仅在 Unity OpenXR: Meta (com.unity.xr.meta-openxr@2.1.0) 及 Unity 6 或更高版本中可用。详情请参阅 Unity OpenXR:Meta。
  • 对于版本低于 1.9⁠ 的 OpenXR,设置跟踪原点 STAGE 需要在更新世界原点之前重新居中。

安装 Unity OpenXR 插件

所有新项目都应安装 Unity OpenXR 插件,以获得最新功能与优化带来的优势。
如要安装 OpenXR 提供方插件,请执行以下操作:
  1. 在 Unity 编辑器 6000.0.66f2 或更高版本中打开任意一个 3D 项目(推荐使用 6.1 或更高版本)
  2. 在 Unity 编辑器的顶部菜单中,前往 Edit(编辑)> Project Settings(项目设置),打开 Project Settings(项目设置)窗口。
  3. 在 Project Settings(项目设置)窗口中,选择 XR Plug-in Management(XR 插件管理)。
  4. 如果未安装 XR 插件管理,则选择 Install XR Plugin Management(安装 XR 插件管理)。
  5. 在 Windows, Mac, Linux settings(Windows、Mac 和 Linux 设置)选项卡中,选择 OpenXR。
  6. 在 Android, Meta Quest settings(Android、Meta Quest 设置)选项卡中,选择 OpenXR。
  7. 关闭 Project Settings(项目设置)窗口。
  8. 在 Unity 编辑器的顶部菜单中,前往 Window(窗口)> Package Management(包管理)> Package Manager(包管理工具),打开 Unity Package Manager(Unity 包管理工具)窗口。
  9. 确保左侧导航菜单中的 In Project(在项目中)突出显示。在 Search in Project(在项目中搜索)下,展开 Packages - Unity(包 - Unity)下拉菜单。
  10. 在左侧菜单中的包列表中,确认 OpenXR Plugin(OpenXR 插件)旁边有一个勾选标记,这表明该包已安装。
如需进一步了解如何设置 OpenXR 插件,请参阅 Unity OpenXR 插件设置文档。

Unity OpenXR:Meta

Unity OpenXR 插件本身不支持 Depth API 遮挡功能。如要将遮挡集成到基于 Unity OpenXR 插件构建的项目中,你必须使用 Unity OpenXR:Meta (com.unity.xr.meta-openxr@2.1.0)⁠。
安装 Unity OpenXR:Meta:
  1. 在 Unity 6 中打开 Package Manager(包管理工具)。
  2. 选择 Unity 注册表
  3. 搜索 Unity Open XR Meta 包
    Install Unity Open XR Meta package
注意:此操作会将 ARFoundation 和 OpenXR 包作为依赖项安装到你的项目中。

Oculus XR 插件

Oculus XR Plugin is deprecated
Oculus XR 插件已停用并计划移除。请改用 Unity OpenXR 插件。
Unity 通过 Oculus XR 插件支持在 Meta Quest 头戴设备上开展 XR 开发。Oculus XR 插件提供了如渲染模式、深度缓冲区共享以及延迟优化等常见的生命周期管理和运行时设置选项。
Meta XR 核心 SDK 包含 OVRPlugin,提供内置编辑器支持和若干附加功能。将 OVRPlugin 和 Unity 的 Oculus XR 插件结合使用,可使 Unity 能够与 Meta Quest 头戴设备上的 OpenXR、VRAPI 和 CAPI 后端进行交互。Meta 已将 OpenXR 运行时设为默认后端,旨在加快 OpenXR 的采用速度,同时让你能够运用相同的 API 无缝适配各种 Meta AR/VR 头戴设备。所有新功能仅在 OpenXR 后端可用。
Meta XR Architecture Diagram
Unity 的 Oculus XR 插件提供在 Meta Quest 头戴设备上运行 XR 应用程序的基础功能。当项目需要用到最新功能时,我们建议采用 Meta XR 核心 SDK 包。Meta XR 核心 SDK 包含最新版的 OVRPlugin,以及一些实用 C# 脚本,用于开放 Unity API 暂不支持的 Meta Quest 功能。例如,呈现平台、语音、手势追踪、互动等高级功能可借助 Meta XR 核心 SDK,而非通过 Unity API 实现。

安装 Oculus XR 插件

如果项目使用 Unity 6 以下版本,且 Meta XR SDK 版本低于 v74,请安装 Oculus XR 插件。
安装 Oculus XR 提供方插件的步骤如下:
  1. 在 Unity 编辑器(2022 或 2023 版本)中打开任意 3D 项目。
  2. 在 Unity 编辑器的顶部菜单中,前往 Edit(编辑)> Project Settings(项目设置),打开 Project Settings(项目设置)窗口。
  3. 在 Project Settings(项目设置)窗口中,选择 XR Plug-in Management(XR 插件管理)。
  4. 如果未安装 XR 插件管理,则选择 Install XR Plugin Management(安装 XR 插件管理)。
  5. 在 Windows, Mac, Linux settings(Windows、Mac 和 Linux 设置)选项卡中,选择 Oculus。
  6. 在 Android settings(Android 设置)选项卡中,选择 Oculus。
  7. 关闭 Project Settings(项目设置)窗口。
  8. 在 Unity 编辑器的顶部菜单中,前往 Window(窗口)> Package Management(包管理)> Package Manager(包管理工具),打开 Unity Package Manager(Unity 包管理工具)窗口。
  9. 在窗口左上角,展开 Packages - Unity(包 - Unity)下拉菜单。
  10. 在左侧菜单中的包列表中,确认 Oculus 插件旁边有一个勾选标记,这表明该包已安装。
注意:安装 XR 插件并不会下载 Meta XR SDK,也不会将其导入到项目中。请前往 Unity Asset Store⁠添加你需要的 Meta XR SDK。

升级至最新版 XR 插件

某些运行时设置可能仅在最新版本中提供。
如要升级至最新的可用插件版本,请执行以下操作:
  1. 在 Unity 编辑器的顶部菜单中,前往 Window(窗口)> Package Management(包管理)> Package Manager(包管理工具),打开 Unity Package Manager(Unity 包管理工具)窗口。
  2. 在 Package Manager(包管理工具)窗口的顶部菜单中,展开 Packages:(包:)下拉菜单,然后选择 Packages: Unity Registry(包:Unity 注册表)。
  3. 在左侧菜单的软件包列表中,选择 Oculus XR Plugin(Oculus XR 插件)或 Unity OpenXR Plugin(Unity OpenXR 插件)。
  4. 在详细视图中,选择 Version History(版本历史)选项卡,查看可用的升级操作。

卸载 XR 供应商插件

从 XR 插件管理界面禁用 XR 插件包不会自动卸载该插件。你需要通过包管理工具窗口将该插件移除。
  1. 在菜单上,前往 Window(窗口)> Package Management(包管理)> Package Manager(包管理工具)。
  2. 在包管理工具窗口的顶部菜单中,展开 Packages:(包:)下拉菜单,然后选择 Packages: In Project(包:在项目中)。
  3. 在左侧菜单的软件包列表中,选择 Oculus XR 插件 或 OpenXR 插件。
  4. 在详细视图中,选择移除。