開発

パススルーの基本的なチュートリアル

更新日時: 2025/12/09
これは、パススルーの実装を短時間でテストするための基本的なチュートリアルです。パススルーをプロジェクトに統合するには、このチュートリアルを完了することを強くおすすめします。このチュートリアルを完了後、他のパススルーチュートリアルのスタータープロジェクトとしても使用できます。

前提条件

このチュートリアルを始める前に、必ず以下のチェックリストをすべて確認してください。

ハードウェアの要件

  • 以下のいずれかのOSで動作する開発マシン。
    • Windows 10以降(64ビット)
    • macOS 10.10以降(x86またはARM)
  • サポートされているMeta Questヘッドセット:
    • Quest 2
    • Quest Pro
    • Quest 3
    • Quest 3Sおよび3S Xbox Edition

ソフトウェアの要件

  • Unityバージョン6.1以降を推奨します。

アカウントの要件

1.Meta XR Core SDKをインストールする

UnityパッケージマネージャでMeta XR SDKをインポートするのトピックで説明されている手順に従って、Meta XR Core SDKをダウンロードします。
Meta XR機能セットを有効にするように求められたら、[Enable (有効にする)]を選択します。プロンプトが表示されない場合は、[Edit (編集)] > [Project Settings (プロジェクト設定)]に移動して機能セットを有効にします。[XR Plug-in Management (XRプラグインマネジメント)]を選択してから、スタンドアロンタブとMetaグループタブの両方で[Meta XR Feature group (Meta XR 機能グループ)]が選択されていることを確認します。

2.ターゲットプラットフォームをAndroidに設定する

  1. メニューで、[File (ファイル)] > [Build Profiles (ビルドプロフィール)]の順に移動します。
  2. [Platforms (プラットフォーム)]で[Android]を選択します。
  3. [Switch Platform (プラットフォームの切り替え)]をクリックします。

3.Unity OpenXRプラグインをインストールする

最新機能や最適化のメリットを得るため、すべての新規プロジェクトにはUnity OpenXRプラグインをインストールしてください。
OpenXRプロバイダープラグインをインストールするには、以下の手順に沿って操作します。
  1. Unity Editorの6000.0.66f2以降(6.1以降を推奨)で、任意の3Dプロジェクトを開きます
  2. Unityエディターのトップメニューから、[Edit (編集)] > [Project Settings (プロジェクト設定)]の順に移動し、[Project Settings (プロジェクト設定)]ウィンドウを表示します。
  3. [Project Settings (プロジェクト設定)]ウィンドウで、[XR Plug-in Management (XRプラグイン管理)]を選択します。
  4. XRプラグイン管理がインストールされていない場合は、[Install XR Plugin Management (XRプラグイン管理をインストール)]を選択します。
  5. [Windows, Mac, Linux settings (Windows、Mac、Linuxの設定)]タブで、[OpenXR]を選択します。
  6. [Android, Meta Quest settings (Android、Meta Questの設定)]タブで、[OpenXR]を選択します。
  7. [Project Settings (プロジェクト設定)]ウィンドウを閉じます。
  8. Unityエディターのトップメニューから、[Window (ウィンドウ)] > [Package Management (パッケージ管理)] > [Package Manager (パッケージマネージャ)]の順に移動して、[Unity Package Manager]ウィンドウを開きます。
  9. 左側のナビゲーションメニューで、[In Project (プロジェクト内)]がハイライトされていることを確認します。[Search in Project (プロジェクト内を検索)]の下で、[Packages - Unity (パッケージ - Unity)]ドロップダウンを展開します。
  10. 左側のメニューのパッケージ一覧で、[OpenXR Plugin (OpenXRプラグイン)]の横にチェックマークがあることを確認します。これは、パッケージがインストールされていることを意味します。
OpenXRプラグインの設定方法について、詳しくはUnity OpenXRプラグイン設定ドキュメントをご覧ください。

4.Meta Questヘッドセットをコンピューターに接続する

Meta Questモバイルアプリを開いて、選択したヘッドセットの[Headset Settings (ヘッドセットの設定)]で開発者モードを有効にします。必要に応じて、開発用にヘッドセットを設定するで詳細をご覧ください。
  1. USB-Cケーブルを使用してヘッドセットをコンピューターに接続し、Meta Questヘッドセットを装着します。
  2. ヘッドセットをオンにし、[Settings (設定)] > [Advanced (詳細設定)] > [Developer (開発者)]の順に移動し、[Enable developer settings (開発者設定を有効にする)]と[MTP Notification (MTP通知)]をオンにします。
  3. データへのアクセス許可を求めるプロンプトが表示されたら、[Allow (許可)]をクリックします。
  4. 接続を検証するには、Unityプロジェクトを開き、メニューで[File (ファイル)] > [Build Profiles (ビルドプロフィール)]の順に移動します。
  5. 左側のナビゲーションメニューから[Android]または[Meta Quest]を選択し、[Run Device (実行デバイス)]リストからMeta Questヘッドセットを選択します。ヘッドセットがリストにない場合は、[Refresh (更新)]をクリックしてください。

5.OVRCameraRigを追加する

  1. [Hierarchy (階層)]タブで[Main Camera (メインカメラ)]を右クリックし、[Delete (削除)]をクリックします。
  2. [Project (プロジェクト)]タブで、「OVRCameraRig」を検索します。検索結果にOVRCameraRigが表示されるようにするには、[All (すべて)]または[In Packages (パッケージ内)]で検索を絞り込む必要があります。
  3. OVRCameraRigのprefabをシーンにドラッグ&ドロップします。[Hierarchy (階層)]タブでもドラッグ&ドロップできます。

6.3Dオブジェクトを追加する

  1. メニューで、[GameObject] > [3D Object (3Dオブジェクト)] > [Sphere (球体)]に移動します。
  2. 3Dオブジェクトを選択してから、[Inspector (インスペクター)]タブで位置(X, Y, Z)を(1, 1, 1)に、スケール(X,Y, Z)を(0.5, 0.5, 0.5)に設定します。
  3. [Project (プロジェクト)]タブで、Assetsフォルダーを選択してハイライトします。
  4. メニューで[Assets (アセット)] > [Create (作成)] > [Material (マテリアル)]を選び、そのマテリアルの名前をball-colorに変更します。
  5. [Inspector (インスペクター)]タブの[Surface Inputs (サーフェス入力)]で、[Base Map (ベースマップ)]の色フィールドをクリックして色選択ツールを開き、任意の色に変更します。
  6. マテリアルを球体にドラッグ&ドロップします。

7.パススルーを統合する

  1. [Hierarchy (階層)]タブで[OVRCameraRig]を選択し、[Inspector (インスペクター)]タブで次のようにします。
    a.OVRManager > [Tracking (トラッキング)]で、[Tracking Origin Type (トラッキング原点タイプ)]を[Stage (ステージ)]に設定します。
    b.OVRManager > [Quest Features (Questの機能)] > [General (一般)]で、[Passthrough Support (パススルーサポート)]リストから[Supported (サポート対象)]を選択します。
    c.[Insight Passthrough & Guardian Boundary (インサイトパススルーとガーディアン境界線)]で、[Enable Passthrough (パススルーを有効にする)]にチェックを入れます。
  2. シーンに新しい空のGameObjectを作成し、その[Inspector (インスペクター)]タブに移動します。[Add Component (コンポーネントを追加)]をクリックし、[Script (スクリプト)]で[OVR Passthrough Layer (OVRパススルーレイヤー)]を選択します。
  3. メニューで[Window (ウィンドウ)] > [Rendering (レンダリング)] > [Lighting (ライティング)]に移動し、[Environment (環境)]タブの[Skybox Material (スカイボックスマテリアル)]で[None (なし)]を選択します。検索ボックスになしと入力することで、スカイボックスマテリアルを簡単に「なし」に設定できます。
  4. [Hierarchy (階層)]タブで[OVRCameraRig] > [TrackingSpace] > [CenterEyeAnchor]を展開し、[Inspector (インスペクター)]タブで次のようにします。
    a.[Environment (環境)]セクション(以前のバージョンのUnityの場合は[Clear Flags (フラグをクリア)])を展開し、[Background Type (背景タイプ)]が[Solid Color (単一色)]に切り替えられていることを確認します。
    b.[Background (背景)]の色を黒に、アルファ値を0に変更します。また、(R,G,B,A)の値を(0, 0, 0, 0)に設定することもできます。

ビルドとテスト

  1. プロジェクトを保存します。
  2. メニューで、[File (ファイル)] > [Build Profiles (ビルドプロフィール)]の順に移動します。[Android]または[Meta Quest]の下で、自分のシーンがシーンリストに含まれていることを確認します。含まれていない場合は、[Open Scene List (オープンシーンリスト)]をクリックしてから、[Add Open Scenes (オープンシーンを追加)]をクリックして追加します。
  3. [Run Device (実行デバイス)]が、USBケーブル経由で接続されているMeta Questヘッドセットに設定されていることを確認します。
  4. [Build and Run (ビルドして実行)]をクリックします。
  5. .APKファイルを保存します。
  6. ヘッドセットを装着して、パススルーをテストします。現実の自分の部屋の前にボールが配置されているのが見えるはずです。
    A view of the sphere in passthrough